BSOD After upgrading SPX or Inaccessible boot device

Reference:
https://support.storagecraft.com/s/article/Inaccessible-Boot-device-after-upgrade-to-6-7-x?language=en_US

Uninstall previous version before upgrading SPX.

If it's too late and the BSOD (Inaccessible Boot Device) is showing follow directions above.


Method 1.
If the machine encountered the BSOD and will not boot, proceed to Method 2.

Cause
A disk starts in offline mode. Eventually it will go online, then mount the file system. There are cases when the file system starts to mount the disk but the disk is not online yet.  If this occurs, the blue screen error code will appear.   
Resolution
There are four methods to bypass the blue screen error after it has been encountered. 

MSFT_Signed_stcvsm-2.2.73.0.36.zip
  • Install SPX 6.7.x.
  • Do not reboot.
  • Rename %windir%\system32\drivers\stcvsm.sys to %windir%\system32\drivers\stcvsm-rtm.sys.
  • Copy the 2.2.73 driver to %windir%\system32\drivers.  Be sure to select the correct version for the operating system in question, either x64 or x86.
  • Reboot the machine.
  • Resolution 2: 


    MSFT_Signed_stcvsm-2.2.73.0.36.zip

  • Boot to the StorageCraft® Recovery Environment (either the Windows or Crossplatform version will work). Alternatively, if the volume is a VHD/VHDX, it can be mounted and explored through Hyper-V.
  • Identify the OS volume within the Recovery Environment (it might not default to C:).
  • Copy the 2.2.73 driver to %windir%\system32\drivers on the OS volume. Be sure to select the correct version for the operating system in question, either x64 or x86.
  • Reboot the machine.
  • If the issue persists, move to the next method.

  • Method 3 - Edit the registry to remove the driver:

    1. Boot to the Recovery Environment for Windows.
    2. Open Tools > Command Prompt
    3. Type the following command, substituting the correct letter for the system volume as it may be different in the Recovery Environment, and press Enter:
    reg load HKLM\SYSTEM_PROD C:\Windows\System32\Config\SYSTEM
    1. Type in regedit and press Enter. 
    2. In the registry, navigate to:
    HKLM\SYSTEM_PROD\ControlSet001\Control\Class
    1. Search for stcvsm until you find the key for UpperFilter that contains the string stcvsm.
    2. Edit the key and ONLY remove stcvsm, retaining the rest of the text.
    3. Repeat steps 5 through 7 under ControlSet002.
    4. Close the Registry Editor.
    5. Run the following in the command prompt:
    reg unload HKLM\SYSTEM_PROD
    1. Exit and reboot.

    Method 4 - Attempt Booting into Last Known Good Configuration:

    1. Boot into the advanced startup options by pressing F8.
    2. Select Last Known Good Configuration (advanced).

    If all of these methods fail, open a case with StorageCraft Support for further troubleshooting.